Introduktion av Microsoft FrontPage Express

FrontPage Express är ett redigeringsprogram för webbsidor som använder sig av HTML (Hypertext Markup Language). Du kan använda FrontPage Express för att skapa och formatera webbsidor i HTML. Om du arbetar i visningsläget WYSIWYG ("what you see is what you get") kan du direkt se hur formatering och layout kommer att se ut på den färdiga sidan.

FrontPage Express är även kompatibelt med guiden Anpassa den här mappen (på Visa-menyn i Den här datorn), vilket gör att du lätt kan anpassa en mapp efter dina behov.

Med hjälp av de följande lättanvända funktionerna i FrontPage Express kan du skapa mycket avancerade webbsidor:

  • Infoga HTML-koder från verktygsfältet utan att behöva skriva in dem manuellt.
  • Markera text eller stycken och formatera eller justera dem genom att klicka på en knapp i verktygsfältet.
  • Infoga bilder eller clipart från din favoritsamling (FrontPage Express innehåller inga samlingar).
  • Öppna befintliga webbsidor direkt från World Wide Web (om du har installerat Webbpubliceringsguiden) eller direkt från datorn eller nätverket.
  • Spara webbsidan direkt på World Wide Web (med Webbpubliceringsguiden) eller i en fil.
  • Infoga remsor (rullande text).

FrontPage Express innehåller många av funktionerna i Microsoft FrontPage Editor, fast i ett mindre paket. Det är enkelt att uppgradera till FrontPage utan att behöva lära sig ett nytt program eller en ny metod för att skapa webbsidor. FrontPage innehåller även funktionerna FrontPage Editor och FrontPage Explorer.


Anpassa mappar med Webbvy

Allt du kan göra på en webbsida kan du nu göra i vilken mapp som helst på hårddisken.

När du visar innehållet på din dator med Webbvy kan du anpassa bakgrunden på alla mappar genom att använda guiden Anpassa den här mappen (på Visa-menyn i Den här datorn). Du kan även konvertera mappar till webbsidor med guiden och FrontPage Express.

När din mapp är en webbsida kan du använda FrontPage Express för att lägga till länkar till Outlook Express eller någon annan komponent, infoga ActiveX-kontroller, anpassa teckensnitt och teckensnittstorlekar och lägga till vattenstämplar. Du kan använda funktionen för att skapa mappar som exakt motsvarar dina behov.


Avancerade funktioner i FrontPage Express

Med hjälp av de följande lättanvända funktionerna i FrontPage Express kan du skapa mycket avancerade webbsidor:

  • Lägga till bakgrundsfärger och vattenstämplar.
  • Använda WebBot-komponenter i stället för komplicerad programmering. En WebBot-komponent är ett "dynamiskt objekt" på en webbsida som körs när webbskribenten sparar sidan på webbservern eller, i vissa fall, när användaren visar sidan. FrontPage Express innehåller WebBot-komponenter som lägger till funktioner som Tidsstämpel, Inkludera och Sök på webbsidor. (Om du vill ha fler WebBot-komponenter, t ex för formulärhantering, navigeringsfält och mycket mer, kan du uppgradera till Microsoft FrontPage.)
  • Använda ActiveX-kontroller för att utöka din webbsida.

  • Infoga ny HTML-kod när den blir tillgänglig med hjälp av kommandot HTML-kod.

  • Visa och redigera HTML-kod direkt på webbsidan. Färgkodningen i FrontPage Express gör det enkelt att särskilja koder från innehåll.


Gå vidare med FrontPage

När du känner dig redo att skapa mer avancerade webbsidor kan du börja använda Microsoft FrontPage. Du kommer att känna igen produkten eftersom FrontPage Express bygger på FrontPage Editor i Microsoft FrontPage.

Microsoft FrontPage är ett heltäckande programpaket för webbskribenter och webbadministratörer. FrontPage Express och FrontPage utgör tillsammans en bra kombination av enkla visnings- och redigeringsfunktioner (FrontPage Express) och fullständiga funktioner för visning, redigering och webbadministration (FrontPage).

FrontPage innehåller en fullständig webbskribentsmiljö med stora möjligheter:

  • Med FrontPage Editor kan du skapa, visa och spara HTML-dokument. Programmet innehåller mallar, guider och WebBot-komponenter som du kan använda för att skapa webbsidor. Eftersom FrontPage Editor även har en webbläsarfunktion kan du använda programmet för att importera webbsidor från Internet eller ett intranät.
  • Med FrontPage Explorer kan du administrera, visa och redigera en webbplats. Du kan utveckla och testa en webbplats på din dator och sedan kopiera hela platsen till en webbserver. Du kan även använda FrontPage Explorer som en webbserver och sköta en webbplats från skrivbordet, antingen som en del i ett intranät eller som en allmän webbplats på World Wide Web.